Annonce
Robert Bira · Oct 17, 2022

VS Code Server Manager franchit une étape importante avec la version 3.2.1

Hourra pour la sécurité !

Si vous vous connectez à un serveur local et effectuez un développement isolé avec un compte jetable, stockez simplement votre mot de passe en texte brut dans le fichier de configuration settings.json. Mais si vous travaillez avec un serveur partagé en utilisant un "vrai" compte d'utilisateur, c'est une bonne idée de protéger ces informations.

C'est pourquoi c'est un grand jour pour les développeurs ObjectScript soucieux de la sécurité. La version 3 de Server Manager sort de l'état de pré-version avec la première version publique de la version 3.2.1. Cette version concerne la transition vers l'API du fournisseur d'authentification de VS Code pour le stockage des mots de passe chiffrés. Cette API est déjà utilisée par VS Code pour s'authentifier auprès des fournisseurs GitHub et Microsoft, vous pouvez donc être sûr qu'elle a été soigneusement testée au combat. Tirer parti de la même fonctionnalité d'authentification nous aligne sur notre mission principale en matière d'outils de développement, qui est de bien s'intégrer à la technologie traditionnelle et de ne s'écarter de cette voie que lorsque cela est absolument nécessaire. Félicitations et merci à @John Murray pour avoir dirigé le développement de cette fonctionnalité. Assurez-vous que vous exécutez l'extension ObjectScript version 2.x

Si vous utilisiez la version 2.x du gestionnaire de serveur et que vous stockiez les mots de passe dans le trousseau de votre système d'exploitation (PAS en texte brut dans un fichier de configuration VS Code), vous devrez suivre ces étapes pour migrer ces mots de passe chiffrés vers le nouveau fournisseur d'authentification.

Installation

Si les extensions ObjectScript - ObjectScript, Server Manager et Language Server - sont déjà installées, accédez à votre volet Extensions et assurez-vous qu'elles sont à jour. "InterSystems ObjectScript" doit être à la v2.0.0, "InterSystems Server Manager" doit être à la v3.2.1 et "InterSystems Language Server" doit être à la v2.1.2.

Si, pour une raison quelconque, vous n'avez pas encore essayé ces extensions, installez VS Code d'ici. Installez ensuite "InterSystems ObjectScript Extension Pack" de VS Code Marketplace en cliquant sur le bouton vert "Installer".

0
0 10
Discussion (0)2
Connectez-vous ou inscrivez-vous pour continuer